Talk:Myths of the White Lands

From the RuneScape Wiki, the wiki for all things RuneScape
Jump to: navigation, search
This talk page is for discussing the Myths of the White Lands page.

Untitled[edit source]

The update calls this quest "Myths of the White Lands". Can someone fix the case-ness of the last two words? Thnx Hatchenator 15:45, 16 December 2008 (UTC)

Thank you Khalym95! Hatchenator 15:54, 16 December 2008 (UTC)

Requirements[edit source]

can you get the extra xp after u do the quest?Flame8758 22:20, 16 December 2008 (UTC)Flame


I sorely doubt that level 98 magic is recommended for this quest. Bf2142pwner 15:58, 16 December 2008 (UTC), at your service.

Thanks.


I agree. Why would Jagex release a short quest that involves having lv 98 magic?

Cund4 16:03, 16 December 2008 (UTC)

Also, why is there a requirement of at least fifty teleports? Bf2142pwner 16:26, 16 December 2008 (UTC)

Does the page really have to have two reward sections?

Cund4 16:21, 16 December 2008 (UTC)


Mention that in room 5 of mazes, you can get 10k agility xp by climbing the roots! Victory Guy8 16:25, 16 December 2008 (UTC)

woot i finished first in my world (60) at 15:44 gmt. Green partyhat.png Bob2006ty(RUNESTORM333)  talk Green partyhat.png 16:43, 16 December 2008 (UTC)

Are the crafting and woodcutting xp awards for f2p as well? Or are they only p2p? Bf2142pwner 16:47, 16 December 2008 (UTC)

I am f2p and got the crafting xp, but my woodcutting os only 71 so i cant tell you if the woodcutting xp are for f2p's to =b FredeTalk 17:19, 16 December 2008 (UTC)

How long before you can talk to Explorer Jack about the dung. Does your choice make a difference?89.243.145.57 16:53, 16 December 2008 (UTC)

Also, could someone double check whether ftp players with 55+ agility can receive the agility reward exp? (Somewhat unlikely) 130.126.211.130 22:49, 16 December 2008 (UTC)

Hey, this is unclear as to how the quest works for f2p. That is to say, while f2p can do it...but not all of the benefits can be done by free players....it's on the member's quest list. I don't understand:) `````  —The preceding unsigned comment was added by 86.168.157.139 (talk).

This quest cannot be done by free players anymore. It is now a members quest. ShinyUnown T | C | E 11:43, 23 July 2009 (UTC)

Indeed, my friend, yet permit me to clarify that which may confuse some: Any player who has started this quest to any stage may complete it at any time, on any world. Any player who has completed it may continue to access the Land of Snow through Isidor. However, if you have not yet started, the only way to do it is to become a member. My personal suggestion is to wait until you begin membership and train your skills to a sufficiently high level before completing this quest. However, while this may be ridiculously easy for some players, I have Level 77, and I have been a member for months. Even for hours on end, I was unable to finish it. It is actually harder than it may seem. Ralnon (talk) 23:33, October 8, 2009 (UTC)

Bug abusing[edit source]

In the Trivia section it is said that you can walk on the ice by doing something with a easter ring. Should this be removed as it probably shouldnt be possible? FredeTalk 17:19, 16 December 2008 (UTC)

I'm removing all directions for abusing glitches now.
Bug abuse directions removed. 69.27.21.253 01:17, 19 December 2008 (UTC)

Return to the White Lands[edit source]

Can anyone who has finished the quest confirm whether or not we can return to the White Lands caves after the quest is completed? I want to know whether I can finish the quest right now and return for the XP afterwards.--Diberville 17:33, 16 December 2008 (UTC)

You can return. Bring hammers, chisels and hatchets to sell

Discussion[edit source]

I'm stuck on Room 2... the walkthrough only brings me to the wall.. which I chiseled. But it gives no indication on moving into the next cave.--Lom109 17:48, 16 December 2008 (UTC)

I'm having a big problem with the walkthrough for the room with the roots to climb. The instructions don't seem bring me to the exit or roots. Maybe I'm just being stupid or something. Can someone put the correct solution up or confirm that its wrong?--Lirrae 18:04, 16 December 2008 (UTC)



I'm totally stuck in room3 (agility cavern). I'm a free player and it won't let me slide diagonally??!!Kayreeed 03:03, July 11, 2010 (UTC)

Actually never mind about my question. I've finished it.Kayreeed 03:35, July 11, 2010 (UTC)


I'm stuck at room 2. I can't move back to the door where room 1 is, so I can restart. - xxminakoaino220.255.2.74 23:33, October 11, 2012 (UTC)

Room 7[edit source]

Hey All, Im New 2 All This..Room 2 Is Not Impossible. Read The Guide Carefully(Dont Forget That u Can Move Diagonally!).Room 7 I Find Interesting.Very Hard, It Says East First Which Takes u Straight to The Yeti,Which Roars At u And Pushs u Back. I Tryed Several Times And Got to The First Block Push, After That The Guide Is Wrong And Needs to be Changed! IM UNKNOWN AS A USER (Whats The Date?) :D


Whoever drew up the path for this room is a complete and utter moron and needs to be executed immidiatly due to their extream amount of stupidity.

^Whoever wrote that previous message is a complete and utter moron and needs to be executed immediately* due to their extreme* amount of stupidity.

How to push blocks?[edit source]

How do you push the blocks? When I try to move one, it says it's stuck. immibis 21:11, 16 December 2008 (UTC)

Superg98: Well if u stand in front of a block and u push it, it will go into the opposite direction (so lets say u stand north of the block, then it should slide to south) This isn't possible if the block is standing AGAINST A WALL, then its obvious u cant move it. Try to stand in a good direction in front of the block so that the opposite side doesnt stand against a wall. Logic.

Hi! I had the same problem. You need to head into the Yeti location first before you are able to push the blocks. Until you do this you will be unable to move them. Good Luck!
Bonziiznob Talk

22:58, 16 December 2008 (UTC)

Yea...um...Where is the Yeti? I did like 6 rooms until I found out I can't push the blocks.Santa hat.png Powers38 おはようヾ(´・ω・`) 01:21, 17 December 2008 (UTC)
The yeti is in room directly across the room where you start pushing those blocks. In that room (The one with the unmoveable blocks), click so that your character goes east into the yeti room (Theres no walls ect. blocking you from entering the yeti room, It's just directly east, one click and you'll end up in the yeti room). As you enter the yeti room, the yeti will roar at you and send you back into the previous room (where the blocks are again). The roar made things in the cave rumble, therefore making the blocks moveable. So you should be able to move the blocks after the yeti roars at you.

music[edit source]

cavernous mythology
Winter funfair

Room 1[edit source]

(Referring to the walk through) I just cant move diagonally at the last part. No matter where i click, i keep going straight. Nid help plz. --Sbstransit 03:32, 17 December 2008 (UTC)

diagnoly[edit source]

how do you move diagnoly? i've tried at least 5 times to go diagnoly but i can't12.216.165.50 13:00, 19 December 2008 (UTC)

X 0 X
0 Y 0
X 0 X

your character is Y and X's and 0's are the squares surrounding him if you havent move diagonally before your character will be looking at a 0-square so just symply click on a X-square (X-squares are surrounding your character not on another place, if you still misses try moving the camera until its appear to be exactly over your character)

If you do it right Congratulations you learned how to move diagonally. Hope this helps =D --Edd eX 16:29, 21 December 2008 (UTC)

Might be helpful in understanding the above explanation: Click right beside your character rather than far away from him/her.

~Tiffany

XP[edit source]

I didn't have 80 woodcutting when I first completed this quest, so I could't get the XP. Can I still get it by going back there, as a free player? Ancient talisman.png Oil4 Talk 14:40, September 11, 2009 (UTC)

(A bit late, but...)Yes, you can, as long as you've done the quest. Quest point cape detail.png Brux Talk 17:31, March 18, 2010 (UTC)

bonus xp[edit source]

I did the qurest in f2p when it first came out. now i've gone back to get the wc and craft xp, i'm on the platform which gives crafting. What do i click to get xp now? I have the craft lvl needed, and hammer and chisel, but nothing happens when i use one or the other with the wall. the guide mentions stalactites but none are actionable.

66.65.249.197 15:24, September 20, 2010 (UTC)

I can't go back. The dialogue doesnt have an option to go back.  —The preceding unsigned comment was added by 71.221.246.114 (talk).

Uh, what go back option? You can't go back to the white lands after you are done the quest. Exploror Jacks only says you should, but you can't actually Dragon longsword.png Cire04 TalkAttack.png 00:50, June 24, 2012 (UTC)
Yeah I just figured it out. You have to visit the isidor guy in the wizards tower.

4th cavern[edit source]

ok when ever i try to go diagonallyy south east he always goes EAST no matter WHERE I GODAM CLICK!!!! i did the north-east diagonal only three steps before but when i try to go soutth-east he goes EAST!!!! WHY?!?!?  —The preceding unsigned comment was added by 71.98.201.78 (talk) on 11:20, July 28, 2013.

Fourth Cavern - agility xp[edit source]

I've gotten to the vines but I can't do anything but Examine on the roots. Is this a bug or is there something I need to do/bring to climb the vines?

Jaspotn (talk) 10:24, February 23, 2014 (UTC)