Forum:Upgrading MediaWiki parser

From the RuneScape Wiki, the wiki for all things RuneScape
Jump to: navigation, search
Forums: Yew Grove > Upgrading MediaWiki parser
Archive
This page or section is an archive.
Please do not edit the contents of this page.
This thread was archived on 8 March 2009 by Azaz129.

I put in a bug report on Wikia central about some unusual behavior I was encountering with a template I've been working on, and I got an interesting reply from [[w:User:Uberfuzzy|User:Uberfuzzy]]

See:

[[w:Forum:Tag template "function" not working with wikia]]

The gist of this is that some of the behavior of the more complicated templates may be changing with a parser upgrade that is going to happen pretty soon (and should be happening even now). When the software upgrade happens to version 1.14 of MediaWiki, it is possible that some of the templates may be broken and require a bit of tweaking.

I'm giving this a bit of heads-up for those wanting to help out with maintaining some of the more complicated aspects of this wiki. To the best of my knowledge, this isn't going to impact the GEMW pages or any of the Calculators, but it may impact some of the more complicated formatting and navigation templates. If there are any templates or parts of this wiki that might be impacted, please indicated below, or certainly leave a note on RuneScape:Administrator requests if you see something that is broken. --Robert Horning 13:33, 19 January 2009 (UTC)

Hopefully this will fix the #ifexist/template bug... Administrator Hurston (T # C) 14:24, 19 January 2009 (UTC)
If you're talking about the issue I think you're talking about (the tnavbar problem), it wasn't a bug. It was just coded incorrectly, and I've already fixed it. Supertech1 TCE 21:35, 22 January 2009 (UTC)
From what I am seeing neither of the last two attempts to correct this issue have worked. ~kytti khat 07:37, 24 January 2009 (UTC)
Kytti is right. I'm afraid your change (super) only made it change the wanted pages link from 'Template talk' to 'Talk', which was wrong anyway. My effort, whilst it fixed a problem, did not fix this problem. I'm not sure the new parser is on yet, so we will see what effect that has... Administrator Hurston (T # C) 09:32, 24 January 2009 (UTC)

I have found something that will tell us if the parser is on. Which parser is in use? new pp. So we are still on the old parser. Using new pp would be nice, although I do wonder if there are any pages that will need fixing. - TehKittyCatTalk Wikian-Book 02:42, 5 February 2009 (UTC)

I am fixing all of the pages that may/will have problems with the parser changes. The parser changes require a much stricter following of (x)html and wikitext. So no more un-terminated tags that need an end tag. I think we may need to bring up changing signature policies to make them (x)html compliant and standardized where possible. - TehKittyCatTalk Wikian-Book 20:48, 7 February 2009 (UTC)
By the way, we are switching over on March 3rd, we are in the last group to switch. - TehKittyCatTalk Wikian-Book 20:50, 7 February 2009 (UTC)