Forum:So, about Jagex GE API bugs

From the RuneScape Wiki, the wiki for all things RuneScape
Jump to: navigation, search
Forums: Yew Grove > So, about Jagex GE API bugs
Archive
This page or section is an archive.
Please do not edit the contents of this page.
This thread was archived on 18 May 2015 by Iiii I I I.

For the last twelve days, Jagex's GE API has been returning 0 for certain items. This has been messing with price graphs and calculators, not to mention misleading. An extreme example of such is Shadow dye, where the price is off by 500 million coins. What should be done about this? --Jlun2 (talk) 20:43, May 12, 2015 (UTC)

Discussion

This has definitely been discussed, in particular with the people who run bots that update those prices Zaros symbol.png KDanger Talk 20:48, May 12, 2015 (UTC)

Yeah, I'll make it throw an error "soon" (tm). (In seriousness, probs tonight. Had more pressing things to work on) svco4bY.png3Gf5N2F.png 20:49, May 12, 2015 (UTC)
Well.... Since I reinstalled Windows, I am having issues getting TyBot to compile and run and actually accept commands. Looking into it, but it might be a while. svco4bY.png3Gf5N2F.png 17:17, May 13, 2015 (UTC)

So why aren't you fixing them in the mean time? MolMan 21:42, May 12, 2015 (UTC)

Comment - I think I've fixed it in the js script, it should allow users to input the price used ingame allowing 20% +/- of the current held price. In the cases where the price is outside that variance, admins and custodians can bypass that check as a fallback. cqm 21:47, 12 May 2015 (UTC) (UTC)

Closed - Category:Exchange items with no price is empty and Cam says it's fixed, so I assume everything's ok now --Iiii I I I 02:31, May 18, 2015 (UTC)